September 20, 2007

Unrecognized CF and SD Cards

Posted in CF Card Issues, SD Card Issues at 11:56 am by sdjf

I found a really cool, well-written wiki page at oesf about how to get your Zaurus to recognize a new CF or SD card which is not already recognizable:

http://www.oesf.org/index.php?title=Updating_the_Zaurus_to_accept_new_CF_cards

sdjf

Advertisements

September 4, 2007

No icon appears. Has my CF card gone bad?

Posted in CF Card Issues, Hardware Adventures, Linux/Zaurus Tips and Tricks, Zaurus Trials and Tribulations at 9:24 am by sdjf

I had a CF card scare the other day. I needed to send copies of some files on my old 128MB CF card to a friend. But my CF modem was plugged in to the CF slot on my Zaurus. So, I tapped on the “Eject card” icon in the taskbar, waited until the networking and CF card icons disappeared, and then removed my modem. Then I inserted my 128MB CF card and waited for the CF card icon to appear. And waited. And nothing happened, no icon appeared.

Read the rest of this entry »»

May 31, 2007

CF Card Overview

Posted in CF Card Issues, Linux/Zaurus Tips and Tricks at 11:55 pm by sdjf

The posts you will find here from August 2006 document what I went through in attempting to use a new CF card that turned out to be physically corrupt.

They serve as unfortunate examples of the kind of output one can get when attempting to check the physical integrity of a bad CF expansion card.
Read the rest of this entry »

August 20, 2006

Final installment: CF card saga

Posted in CF Card Issues, Hardware Adventures at 1:03 pm by sdjf

Tried a few more things on the sage advice of some friends:

bash# /mnt/card/Programs/fdisk /dev/hda1

Unable to read /dev/hda1
bash# /mnt/card/Programs/fdisk /mnt/cf
You will not be able to write the partition table.

Unable to read /mnt/cf
bash#
Read the rest of this entry »

August 15, 2006

My CF card saga continued

Posted in CF Card Issues, Hardware Adventures at 5:40 pm by sdjf

Okay, remember I bought a generic CF card. But it shows Hyperstone Model 1 on cardctl ident. Hmmm…..might be interesting to google Hyperstone Model 1! Found:

“Basically I want to make work a lucent orinoco card om my laptop. … 2.0 or 2.1 pccard1: CIS info: Hyperstone, Model1 pccard1: Manufacturer code 0x0, …”
lists.freebsd.org/pipermail/freebsd-mobile/2003-August/001409.html

I don’t understand all the output or follow the thread (I have no laptop experience) but maybe it is a lemon they wanted to disguise?

Tried comparing both old cards to new empty card… Read the rest of this entry »

August 13, 2006

Difficulty umounting CF card

Posted in CF Card Issues, Hardware Adventures at 3:27 pm by sdjf

According to the how-to for my distro at oesf,

http://www.oesf.org/index.php?title=Step-by-step_CF/SD_fdisk/formatting_for_newbies

the first step in formatting a card is to umount the card, but it doesn’t seem to work on any of my cf cards!

First tried with new card after did ls -l for the heck of it. Then tried umount and a bunch of guesses:

bash# ls -l /mnt/cf
lrwxrwxrwx 1 root root 15 Dec 31 2001 /mnt/cf -> /usr/mnt.rom/cf
bash# ls -l /mnt/cf/
-rw-rw-r-- 1 root root 0 Aug 13 00:41 NotAvailable
bash# umount /mnt/cf
umount: /mnt/cf: Invalid argument
bash# umount /mnt/cf/
umount: /mnt/cf/: Invalid argument
bash# umount /mnt/card
bash# umount /mnt/hda1
umount: /home/system/var/mnt/hda1: No such file or directory
bash# umount /usr/mnt.rom/cf
umount: /usr/mnt.rom/cf: Invalid argument
bash#
Read the rest of this entry »